summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-25 21:57:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-25 21:57:53 +0200
commit8902aaf0656ae2092e697a6514b0cea383987d7a (patch)
tree5653703c57d9b1565820d512e1411867d7418eac /dev-python/ply/ply-3.11-r1.ebuild
parentdev-python/pycparser: Remove py2.7 (diff)
downloadgentoo-8902aaf0656ae2092e697a6514b0cea383987d7a.tar.gz
gentoo-8902aaf0656ae2092e697a6514b0cea383987d7a.tar.bz2
gentoo-8902aaf0656ae2092e697a6514b0cea383987d7a.zip
dev-python/ply: Remove py2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ply/ply-3.11-r1.ebuild')
-rw-r--r--dev-python/ply/ply-3.11-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ply/ply-3.11-r1.ebuild b/dev-python/ply/ply-3.11-r1.ebuild
new file mode 100644
index 000000000000..f96ca8e95cf5
--- /dev/null
+++ b/dev-python/ply/ply-3.11-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.org/project/ply/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+DOCS=( ANNOUNCE CHANGES TODO )
+
+PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${EPYTHON}" "${t}" -v || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r example
+ distutils-r1_python_install_all
+}