summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-22 08:35:07 -0500
committerTim Harder <radhermit@gentoo.org>2018-03-01 14:34:45 -0500
commit6b3b1a21bba38869e147dde1dc5d5094ae9592a8 (patch)
tree7abf23686c82822bf7afa109223cc8a5b38f74e1 /dev-python/ply/ply-3.11.ebuild
parentdev-python/llfuse: remove old (diff)
downloadgentoo-6b3b1a21bba38869e147dde1dc5d5094ae9592a8.tar.gz
gentoo-6b3b1a21bba38869e147dde1dc5d5094ae9592a8.tar.bz2
gentoo-6b3b1a21bba38869e147dde1dc5d5094ae9592a8.zip
dev-python/ply: version bump to 3.11
Diffstat (limited to 'dev-python/ply/ply-3.11.ebuild')
-rw-r--r--dev-python/ply/ply-3.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ply/ply-3.11.ebuild b/dev-python/ply/ply-3.11.ebuild
new file mode 100644
index 000000000000..b5863d7b8c32
--- /dev/null
+++ b/dev-python/ply/ply-3.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.python.org/pypi/ply"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( ANNOUNCE CHANGES TODO )
+
+PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ # Checks for pyc/pyo files
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && dodoc -r example
+ distutils-r1_python_install_all
+}