summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-22 08:51:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-22 09:36:59 +0200
commit5345a1b79f058bb3f8fd9739650f27d8612a5ed1 (patch)
treef8006e7a3c435e44b894b898e2e8cd85122233cd /dev-python/podman-py
parentdev-python/stestr: Bump to 3.2.1 (diff)
downloadgentoo-5345a1b79f058bb3f8fd9739650f27d8612a5ed1.tar.gz
gentoo-5345a1b79f058bb3f8fd9739650f27d8612a5ed1.tar.bz2
gentoo-5345a1b79f058bb3f8fd9739650f27d8612a5ed1.zip
dev-python/podman-py: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/podman-py')
-rw-r--r--dev-python/podman-py/Manifest1
-rw-r--r--dev-python/podman-py/podman-py-3.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/podman-py/Manifest b/dev-python/podman-py/Manifest
index ab2ad9fb16d0..8847f35b0fbc 100644
--- a/dev-python/podman-py/Manifest
+++ b/dev-python/podman-py/Manifest
@@ -1 +1,2 @@
DIST podman-py-3.2.0.tar.gz 165514 BLAKE2B 7e25d160b98e45cc147069249d850b3a3d6dac5227942d90ed99b8313befd9db04a6423015ae56959a53eeeb49958d9067eb6fb7127ee55bf50ebfcea617a220 SHA512 8ef165847de5fecd81e7b5564baeaa0298efd4d2e6f12e1dfe958eed77f945d9375d90ba93a8ebab4b090b228d451e96ce49d08288dc3daae1255a05127b25c7
+DIST podman-py-3.2.1.tar.gz 181095 BLAKE2B 5075a37d3ef20004424536bc1f9e6e08c842248fcb8d8235ebc354e832e78125fb19bd0001f7fd237ebc642e348368da90b634f0db8c84e23ef77e8cf99b71ad SHA512 656a5e61d9809e2866a071ff5b4792fb71fbe0f8cc05467b498718b74898acc39a970ba64fc08ffe70d9c34a9caeabc3d8ea07dcce856fec308b6ebd268b2fb0
diff --git a/dev-python/podman-py/podman-py-3.2.1.ebuild b/dev-python/podman-py/podman-py-3.2.1.ebuild
new file mode 100644
index 000000000000..c0d18e6cc5dc
--- /dev/null
+++ b/dev-python/podman-py/podman-py-3.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}