summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/polib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/Manifest1
-rw-r--r--dev-python/polib/metadata.xml11
-rw-r--r--dev-python/polib/polib-1.0.4.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/polib/Manifest b/dev-python/polib/Manifest
new file mode 100644
index 000000000000..7d88dccc0d65
--- /dev/null
+++ b/dev-python/polib/Manifest
@@ -0,0 +1 @@
+DIST polib-1.0.4.tar.gz 151634 SHA256 8b3276f75ce2fce9442e27db3ae63d842416e17f0e2095f39ff52dc735e5749a SHA512 a38d57acdaded0371be83825a28f14f178aebdbc0435724f33eebda109adb2b8210e33659ebec88d2d9e98aa60c482d7f8a958ec18f6769fda7a2fb14edd2744 WHIRLPOOL 1fe4e5bbf27444c1a6d7d79c70325078d3b2d15f6a5eb84852ccb080dfee4d03a7f8311127b6f93e1cb23ad633155bf93221317ec3518b1c5d7ec52b79fab87d
diff --git a/dev-python/polib/metadata.xml b/dev-python/polib/metadata.xml
new file mode 100644
index 000000000000..3b4d48a8b559
--- /dev/null
+++ b/dev-python/polib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">izi/polib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/polib/polib-1.0.4.ebuild b/dev-python/polib/polib-1.0.4.ebuild
new file mode 100644
index 000000000000..c0ae9d4d89fb
--- /dev/null
+++ b/dev-python/polib/polib-1.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="https://www.bitbucket.org/izi/polib/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ emake html
+ fi
+}
+
+python_test() {
+ python tests/tests.py || die
+}
+
+python_install_all() {
+ local DOCS="CHANGELOG README.rst"
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}