summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/polygon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/Manifest3
-rw-r--r--dev-python/polygon/metadata.xml10
-rw-r--r--dev-python/polygon/polygon-2.0.4.ebuild37
-rw-r--r--dev-python/polygon/polygon-2.0.6.ebuild26
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild40
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
new file mode 100644
index 000000000000..8276f23a5dcf
--- /dev/null
+++ b/dev-python/polygon/Manifest
@@ -0,0 +1,3 @@
+DIST Polygon-2.0.4.zip 73544 SHA256 a9a85d81cc9faabba398001b1e9d32444e98147ac6e31cbdc5ef512c4f7c43dd SHA512 1d1b6a6f601298fc2a05f2fa30ff7ed81feb3e3651f4579524a3f2bb6403ceb404ab7a41545fc742ee8be626d034fd32d5e3554fec56811b1631f8c5b8352dd5 WHIRLPOOL db6342be7594666af6d441b36c825e9c0e8aa333ad5b77c18ca64ac27367b897bd7bcae0ea83fcb748007f3331514d16acafe3101ea1404e04f530441d566d7e
+DIST Polygon2-2.0.6.zip 73551 SHA256 3e0e1a5125e892faa5964523de28c0349b573ed102547e12a1affc3fed2cac3b SHA512 d0827fe3299449842e201598b59e423bf3029302037ffb9329dae0045b2be1727eb33951dfd22f560476360836305526be58e55d9d4cff36f3d9a4b0262b7aed WHIRLPOOL 50b176f05ade1780e21f8280d884996f04df3894a8479b5d82b1410cc53961c0faedea1b20b431b0eeb2996619abf91392e4c9291856a63c8b080605f646c67b
+DIST Polygon3-3.0.7.zip 76193 SHA256 627852f50fd6002b9a59eef291bb38c075d95e67c47a8d3b32713426ee137744 SHA512 e30cd8e51ad69a2d76b61a7d92ead4ac352e729093546b965f649866fd9c6a860e3cdcd9fcd7f8cc9f8d7735ccd1128fb5af00b3de89e4efd7128e446a70b33b WHIRLPOOL 7123420e402e3cb5034ad3ffaba561a8c250e6788ee6b89ca8376ed6a037a889611afcd34f135b1ee16261e2504a22895c491d91a691e1559628673682e1dead
diff --git a/dev-python/polygon/metadata.xml b/dev-python/polygon/metadata.xml
new file mode 100644
index 000000000000..9754f81c78b5
--- /dev/null
+++ b/dev-python/polygon/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ Polygon is a python package that handles polygonal shapes in 2D. It contains
+ Python bindings for gpc, the General Polygon Clipping Library by
+ Alan Murta and some extensions written in C and pure Python.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/polygon/polygon-2.0.4.ebuild b/dev-python/polygon/polygon-2.0.4.ebuild
new file mode 100644
index 000000000000..91a1da4c0613
--- /dev/null
+++ b/dev-python/polygon/polygon-2.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5-jython"
+
+inherit distutils
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="mirror://github/jraedler/Polygon2/Polygon-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/Polygon-${PV}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(dir -d build-${PYTHON_ABI}/lib*)" "$(PYTHON)" test/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc HISTORY doc/Polygon.txt
+}
diff --git a/dev-python/polygon/polygon-2.0.6.ebuild b/dev-python/polygon/polygon-2.0.6.ebuild
new file mode 100644
index 000000000000..b84f17892841
--- /dev/null
+++ b/dev-python/polygon/polygon-2.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://www.bitbucket.org/jraedler/${PN}2/downloads/Polygon2-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon2-${PV}
+
+DOCS=( HISTORY doc/Polygon.txt )
+
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed"
+}
diff --git a/dev-python/polygon/polygon-3.0.7.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
new file mode 100644
index 000000000000..8273280c0139
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="http://www.j-raedler.de/projects/polygon"
+SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="3"
+IUSE="examples"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon3-${PV}
+
+DOCS=( doc/{Polygon.txt,Polygon.pdf} )
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv doc/{Examples.py,testpoly.gpf} examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}