summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-09-17 02:51:14 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-09-17 18:48:37 +0200
commitb1fda0fbff61ccdaa87d395b6798ce05f2ef54a8 (patch)
tree5e20422e59c8445fb4832feacf57245268b5d0ff /dev-python/pooch/pooch-1.2.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.19.146 (diff)
downloadgentoo-b1fda0fbff61ccdaa87d395b6798ce05f2ef54a8.tar.gz
gentoo-b1fda0fbff61ccdaa87d395b6798ce05f2ef54a8.tar.bz2
gentoo-b1fda0fbff61ccdaa87d395b6798ce05f2ef54a8.zip
dev-python/pooch: new package
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17570 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/pooch/pooch-1.2.0.ebuild')
-rw-r--r--dev-python/pooch/pooch-1.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pooch/pooch-1.2.0.ebuild b/dev-python/pooch/pooch-1.2.0.ebuild
new file mode 100644
index 000000000000..42f0780637f9
--- /dev/null
+++ b/dev-python/pooch/pooch-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6..8})
+
+inherit distutils-r1
+
+DESCRIPTION="manages your Python library's sample data files"
+HOMEPAGE="https://github.com/fatiando/pooch"
+SRC_URI="https://github.com/fatiando/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme