summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-14 09:19:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-14 09:35:28 +0100
commitf565e48ae7e669c8e133012ba69906678f732bd1 (patch)
tree32802ef7cf364c93a91764410ea3fcc3f48e8122 /dev-python/portend
parentdev-python/netcdf4-python: Bump to 1.5.6 (diff)
downloadgentoo-f565e48ae7e669c8e133012ba69906678f732bd1.tar.gz
gentoo-f565e48ae7e669c8e133012ba69906678f732bd1.tar.bz2
gentoo-f565e48ae7e669c8e133012ba69906678f732bd1.zip
dev-python/portend: Bump to 2.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-2.7.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index a8d58512150c..d1b8aa10844c 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1 +1,2 @@
DIST portend-2.7.0.tar.gz 12732 BLAKE2B 147d47295d702e6e4a41da1af91afc72ecb2a29713431aada6c98fe527c96f86a88a845cc1afe6507e2fd0d749e146f8b349df13d2e1fb1ff2c0a12fc7d6bdae SHA512 8c81e524e94c4902806a6d33a2811d405e6024796fdbfb5ee1037a177b0aaed4c1b87b76822eee5ca55e552ffa569f4e619d0c1645f0d10c17f8d721ec73787b
+DIST portend-2.7.1.tar.gz 13538 BLAKE2B 56e9b7ae4fb9371322cbecf12d9367fc48f0138cf9fa8cb25cf7f0b7977d83852f328d89e93ee2e266e77b393bbabe75d091ce85f688e1ee146edf64e470aa60 SHA512 079bfc286491753e980b5000ee716031225439523a8d9a79c2571359adee74ee024dd680c41adb966487dc39eea3d0dbeb928c5c72fa21ab897283310ef21906
diff --git a/dev-python/portend/portend-2.7.1.ebuild b/dev-python/portend/portend-2.7.1.ebuild
new file mode 100644
index 000000000000..951cb59e9aec
--- /dev/null
+++ b/dev-python/portend/portend-2.7.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest