summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:49:48 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 23:49:48 -0500
commit903f2f2102b51f68c8a7dc7b13f5aaf562b7f2c4 (patch)
tree073a4125992c2d190fec34fc722e1f6f22a2e7f8 /dev-python/positional/positional-1.0.1.ebuild
parentdev-python/pycadf: adding py35 (diff)
downloadgentoo-903f2f2102b51f68c8a7dc7b13f5aaf562b7f2c4.tar.gz
gentoo-903f2f2102b51f68c8a7dc7b13f5aaf562b7f2c4.tar.bz2
gentoo-903f2f2102b51f68c8a7dc7b13f5aaf562b7f2c4.zip
dev-python/positional: adding for openstack mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/positional/positional-1.0.1.ebuild')
-rw-r--r--dev-python/positional/positional-1.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/positional/positional-1.0.1.ebuild b/dev-python/positional/positional-1.0.1.ebuild
new file mode 100644
index 000000000000..037652a0ef4b
--- /dev/null
+++ b/dev-python/positional/positional-1.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A decorator which enforces only some args may be passed positionally."
+HOMEPAGE="https://github.com/morganfainberg/positional"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"