summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-20 00:04:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-20 12:11:44 +0200
commit281eeea04a539865dea6eb26e9c4bb73475e3093 (patch)
tree4301d763e94dfb4dda9f8c02694edf77496eb68e /dev-python/poyo/poyo-0.4.1.ebuild
parentnet-ftp/ncftp: ppc stable (bug 618880). (diff)
downloadgentoo-281eeea04a539865dea6eb26e9c4bb73475e3093.tar.gz
gentoo-281eeea04a539865dea6eb26e9c4bb73475e3093.tar.bz2
gentoo-281eeea04a539865dea6eb26e9c4bb73475e3093.zip
dev-python/poyo: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/poyo/poyo-0.4.1.ebuild')
-rw-r--r--dev-python/poyo/poyo-0.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/poyo/poyo-0.4.1.ebuild b/dev-python/poyo/poyo-0.4.1.ebuild
new file mode 100644
index 000000000000..6193eadfddad
--- /dev/null
+++ b/dev-python/poyo/poyo-0.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A lightweight YAML Parser for Python"
+HOMEPAGE="https://github.com/hackebrot/poyo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}