summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-04 11:26:41 +0200
committerIan Delaney <idella4@gentoo.org>2016-05-05 16:38:52 +0800
commit35851247185804a0bbcb0f1b3024e5dbcdc170af (patch)
tree4a6a234f28b4f16827e4c7491017e665c3c8c561 /dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
parentsys-fs/iprutils: Version bump. (diff)
downloadgentoo-35851247185804a0bbcb0f1b3024e5dbcdc170af.tar.gz
gentoo-35851247185804a0bbcb0f1b3024e5dbcdc170af.tar.bz2
gentoo-35851247185804a0bbcb0f1b3024e5dbcdc170af.zip
dev-python/pretty-yaml: bump to 15.8.2, EAPI=6
fix DEPEND Gentoo-Bug: 580490 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1400 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild')
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
new file mode 100644
index 000000000000..3bcab79ba0f8
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ "${PYTHON}" pyaml/tests/dump.py || die "tests failed under ${EPYTHON}"
+}