summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-27 08:49:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-27 08:59:39 +0200
commit0d359678d8cffe488df27f605bb55bd5d2351ad0 (patch)
treea0fb9d219c53f4b2237233eb58e2d19f01beec72 /dev-python/prettytable
parentdev-python/curtsies: Bump to 0.3.6 (diff)
downloadgentoo-0d359678d8cffe488df27f605bb55bd5d2351ad0.tar.gz
gentoo-0d359678d8cffe488df27f605bb55bd5d2351ad0.tar.bz2
gentoo-0d359678d8cffe488df27f605bb55bd5d2351ad0.zip
dev-python/prettytable: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-2.2.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index b15e3132566a..f1b0255066cd 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,4 @@
DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
DIST prettytable-2.1.0.tar.gz 43306 BLAKE2B e2085003f2720d573e19fb2b03c8aa98262ec9e7a3f7d0a20474cad2fab374a91664bb513d8158cd612e58a47917c3ebe8b43798272f38c182f6cc2472918f55 SHA512 8eaad22c66299ca3f66cc167e1a94aa41e3b2699da4ff48a0e81927ee8cc623d3147ae29a0bef92370d07d6a7fb6b1eac535fca7090562419aed219b9483edd5
DIST prettytable-2.2.0.tar.gz 44939 BLAKE2B eff6eeb98b6accdb5089cfd1ceb09db2e4a0897e9675a07b744a12ab15fb1cb43bd4a411788d8e22662089f68a31c346d79cfaaca44c7f14f452870a7039bdb6 SHA512 df8ae2a1103a4965a351ba16a95ef9659107075bb023090bd9bffd69805ce647dcb26f49164f07f5af0c0b03503373c0353935b32a0fb18edf969dc984aecda7
+DIST prettytable-2.2.1.tar.gz 45102 BLAKE2B 59fe355603791c8b3a584b1d1f2864559a7e2c7249923d5299c967db74dbd37baef9557d8d5511defe54f64e3f4625ef45635cf2f00a051a599177a3774da1a5 SHA512 5496b1525342b9df4b88cc2cd6079d8c329787b20f7e581465dcdf447b90f78aad764c6505aab8a0e3c4cbb44c943720672373cf754d6f7313b68c28005a707c
diff --git a/dev-python/prettytable/prettytable-2.2.1.ebuild b/dev-python/prettytable/prettytable-2.2.1.ebuild
new file mode 100644
index 000000000000..f2e0a92613a6
--- /dev/null
+++ b/dev-python/prettytable/prettytable-2.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )"
+
+distutils_enable_tests --install pytest