summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-03 21:36:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-03 21:52:58 +0100
commit7866324414f6357985b0314f40f149b925c8e635 (patch)
treef41d15c3f286ac9dce79e5d096e2ff7b8ed8adb7 /dev-python/prettytable
parentdev-python/twine: Bump to 3.5.0 (diff)
downloadgentoo-7866324414f6357985b0314f40f149b925c8e635.tar.gz
gentoo-7866324414f6357985b0314f40f149b925c8e635.tar.bz2
gentoo-7866324414f6357985b0314f40f149b925c8e635.zip
dev-python/prettytable: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-2.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index e2ff20038126..ddb90f2fdc61 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,4 @@
DIST prettytable-0.7.2.tar.bz2 21755 BLAKE2B 385d5bd6d4ab75a8c7ae96abc9d9e98a66a196265853113e7fb59073876e9f5e9c6c4fba9a30d80cc726a5184e78fb6451ff9a553909704fcc5022b6a08413f4 SHA512 f3a3fe6fa29f4ef090ff6cac06549ebd9db8b387e7b25fc64c4e37c8444586f50355c5573f38caabc72360aa68054aa189a67aa37f0bd13b872862ecd9151e71
DIST prettytable-2.2.1.tar.gz 45102 BLAKE2B 59fe355603791c8b3a584b1d1f2864559a7e2c7249923d5299c967db74dbd37baef9557d8d5511defe54f64e3f4625ef45635cf2f00a051a599177a3774da1a5 SHA512 5496b1525342b9df4b88cc2cd6079d8c329787b20f7e581465dcdf447b90f78aad764c6505aab8a0e3c4cbb44c943720672373cf754d6f7313b68c28005a707c
DIST prettytable-2.3.0.tar.gz 49386 BLAKE2B 368dd454da9dde3900009ed52c0d55c30ed69315b36fb53eaebc764af419851b858dc648ac5d8ca62592c2aaa68dac91ac03a1a1bf29d10ee5162981f2937c22 SHA512 feeaeeb0a1897c0aaa2bc0ac7f470244529e8c70debb26976494719607840c8b8a80698b7e463402031b250fe152091e947555be2a6f983764e01bdaa1a71a22
+DIST prettytable-2.4.0.tar.gz 49756 BLAKE2B 594dea7e1c3c9ba070420c83960b9fc4016d25bd883126ed2331cb5ce06909fad92e94ec141e1b4838233f00cfabc394e1a7025aa02cf246e8608903bb45533c SHA512 50983855868d23a590004dcb81ad9a3f22191c656532683f71260a369df5bd2a0001db946268944cc169528f64f36833eb524fc46efabe562434ec32832ce011
diff --git a/dev-python/prettytable/prettytable-2.4.0.ebuild b/dev-python/prettytable/prettytable-2.4.0.ebuild
new file mode 100644
index 000000000000..8065ee6712b7
--- /dev/null
+++ b/dev-python/prettytable/prettytable-2.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest