summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-03 01:10:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-03 01:42:36 +0200
commit1bfb182c1107e7a4a4533366af68e6c35a7b4780 (patch)
tree83affc604e09a61a502734ddd6dd091e6258f753 /dev-python/prometheus_client
parentdev-python/sqlalchemy: Bump to 1.4.5 (diff)
downloadgentoo-1bfb182c1107e7a4a4533366af68e6c35a7b4780.tar.gz
gentoo-1bfb182c1107e7a4a4533366af68e6c35a7b4780.tar.bz2
gentoo-1bfb182c1107e7a4a4533366af68e6c35a7b4780.zip
dev-python/prometheus_client: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus_client')
-rw-r--r--dev-python/prometheus_client/Manifest1
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.10.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/Manifest b/dev-python/prometheus_client/Manifest
index e13f01600409..b44980cdde44 100644
--- a/dev-python/prometheus_client/Manifest
+++ b/dev-python/prometheus_client/Manifest
@@ -1 +1,2 @@
+DIST prometheus_client-0.10.0.tar.gz 71598 BLAKE2B 013b73c3f417fc6102ab6ebe77381b34dee1b6bd7a32af88934ba4dcf6652cd73524de0c489aa2adaa02869c17094eedd95cd87858c9cd2f019001c7fea41a0b SHA512 add7f5dae5f3353df755a1cd74d4a4b08f4217c8eed1880f6abf0ac4629e3179afa6298f93b407babd215b8b6aa84587297da68d6625c27088110e615cb0df10
DIST prometheus_client-0.9.0.tar.gz 68176 BLAKE2B e20f599e6a4d39226e48cafeca879b87389fdb5a6eda401161ce448cb0b46a89ce0cccc1b78e2fc8cb60cc461253345b9ba52809c861f0a187171c33095f625a SHA512 1d68ca35169972c50bb56ede88c47408ee27b3e795fcf03798313aed2dbc5db5532fe6886998c118258b76e431c6e49aa0ac19b9206cad63711901497258aaa5
diff --git a/dev-python/prometheus_client/prometheus_client-0.10.0.ebuild b/dev-python/prometheus_client/prometheus_client-0.10.0.ebuild
new file mode 100644
index 000000000000..b757b986d360
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.10.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus-client/
+ https://github.com/prometheus/client_python/"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/twisted[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest