summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-05-18 10:42:15 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-05-18 10:43:14 +0000
commit78c006dc436da834be0fdfce5b31a58855fad793 (patch)
tree29c47223b4aa1e0095f751cf07590a1207f826a3 /dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild
parentpackage.mask: Removed mask for boost-1.59.0 (diff)
downloadgentoo-78c006dc436da834be0fdfce5b31a58855fad793.tar.gz
gentoo-78c006dc436da834be0fdfce5b31a58855fad793.tar.bz2
gentoo-78c006dc436da834be0fdfce5b31a58855fad793.zip
dev-python/prompt_toolkit: Revert a4d6f73648b542ee6eb3828395a31b336ade521c.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild
new file mode 100644
index 000000000000..d3cd17779255
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-0.52.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.python.org/pypi/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# not contained in tarball
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" "${S}"/tests/run_tests.py || die
+}