summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-15 16:18:00 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:28:30 +0000
commitc4cfbb11a2180f7e62e9a6656e7455229b07c1be (patch)
tree6b00f1a55babbecd13152a0562555b71e52dc349 /dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild
parentsys-kernel/ck-sources: v.bump (4.9.43 & 4.12.7) (diff)
downloadgentoo-c4cfbb11a2180f7e62e9a6656e7455229b07c1be.tar.gz
gentoo-c4cfbb11a2180f7e62e9a6656e7455229b07c1be.tar.bz2
gentoo-c4cfbb11a2180f7e62e9a6656e7455229b07c1be.zip
dev-python/prompt_toolkit: version bump
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild
new file mode 100644
index 000000000000..7543b32f5353
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.python.org/pypi/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test || die
+}