summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 22:55:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 23:58:55 +0100
commit25bf50773427d9ba47336bbed34e449d1f59deaf (patch)
tree234e815cb032b6d17dea346cc925b28afde4528c /dev-python/prompt_toolkit
parentdev-python/weasyprint: Bump to 52.4 (diff)
downloadgentoo-25bf50773427d9ba47336bbed34e449d1f59deaf.tar.gz
gentoo-25bf50773427d9ba47336bbed34e449d1f59deaf.tar.bz2
gentoo-25bf50773427d9ba47336bbed34e449d1f59deaf.zip
dev-python/prompt_toolkit: Bump to 3.0.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 0e66240e5472..f4ffbf2ffdf2 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,3 +1,4 @@
DIST prompt_toolkit-3.0.10.tar.gz 3020391 BLAKE2B 397ab28e5a362c84df7286be27be11acd4c6666bf77d63a1042cd76e6a4ee0b8002bad6166d858dfa6f07f8da41c6513c13fe2500b55da1dbc6562038ed974ef SHA512 71cdbe28064f28a2d88f369ee4550cc02b2609841b51d8fa7e8028304e77f34c6feed5d4549d62a3cbce27f95a4ebca1066a6fd869fbffa1799a3dedef2df6f4
DIST prompt_toolkit-3.0.14.tar.gz 385647 BLAKE2B 08e4483846ba0e6cc69828840a0791e1b85a7db91718042e9a357741164183c0ccd241130c83b980b88884ba32bcb60714c7f920731aa6ca91186ed6f256bafe SHA512 7767861d9f6e5cf88b398420187e4b0a075aaa4645cd8c346db104101f89bbe7c0da2a6518c82066da5efa7376db5144451416ec7b12e92360972f8d4e25d018
DIST prompt_toolkit-3.0.16.tar.gz 3033157 BLAKE2B 6f21544701f956a1e9ec29d049750dc47a6e3861e33a0ccc1e407185ece967c692d3f868e670779dadef3cdf5ec72bd6477e1b3ebfeddd84c267db94efa33f22 SHA512 fd8ebf4ceb61fb823a13bf81ebd6864e817541d08d0744eec8968afe9a9d44bfa95031fe7c53accc81a1612253041e742957aee3718dd18c437d8c3e1b616f35
+DIST prompt_toolkit-3.0.17.tar.gz 3033301 BLAKE2B 86ba94f2e0c9e998c53e5e4ed12961c85c667b6d0356d17cfcb1856aef933f88c1c525507e76a833970444a787641c7316bc7496787ffcd61102945ae91b73bb SHA512 ef78b3aaf953f20a035f8a1f58262a8e4c1ae6b88c02c523bc51237bed22f52e229488d0113901bcd94835cc7120ccb4beb75cc9c9d99dde4e8f21df7bfde8a4
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild
new file mode 100644
index 000000000000..fe628251486f
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest