summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-18 08:54:20 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-18 10:01:07 +0100
commitb503e5abf891e03306ba0063b1a969dc5c55d1fd (patch)
tree09b27303180a98ebf648afe314e3c640646cf78b /dev-python/psutil/psutil-4.0.0.ebuild
parentsci-mathematics/dataplot: Version Bump (diff)
downloadgentoo-b503e5abf891e03306ba0063b1a969dc5c55d1fd.tar.gz
gentoo-b503e5abf891e03306ba0063b1a969dc5c55d1fd.tar.bz2
gentoo-b503e5abf891e03306ba0063b1a969dc5c55d1fd.zip
dev-python/psutil: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/psutil/psutil-4.0.0.ebuild')
-rw-r--r--dev-python/psutil/psutil-4.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/psutil/psutil-4.0.0.ebuild b/dev-python/psutil/psutil-4.0.0.ebuild
new file mode 100644
index 000000000000..1152af09316f
--- /dev/null
+++ b/dev-python/psutil/psutil-4.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} psutil/tests/runner.py || die
+}