summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-02 20:13:20 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-02 20:13:53 -0700
commit11d573c834ebcc6604a6fd948925adb88e3ace41 (patch)
treeb2f0021853e1cd812253e3d32d08a01db7a481b4 /dev-python/psutil/psutil-5.2.2.ebuild
parentwww-client/google-chrome: automated update (58.0.3029.96) (diff)
downloadgentoo-11d573c834ebcc6604a6fd948925adb88e3ace41.tar.gz
gentoo-11d573c834ebcc6604a6fd948925adb88e3ace41.tar.bz2
gentoo-11d573c834ebcc6604a6fd948925adb88e3ace41.zip
dev-python/psutil: version 5.2.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/psutil/psutil-5.2.2.ebuild')
-rw-r--r--dev-python/psutil/psutil-5.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/psutil/psutil-5.2.2.ebuild b/dev-python/psutil/psutil-5.2.2.ebuild
new file mode 100644
index 000000000000..ab3ee8d3bb2f
--- /dev/null
+++ b/dev-python/psutil/psutil-5.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} psutil/tests/runner.py || die
+}