summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-19 07:37:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-19 07:37:42 +0100
commitd20080f1b85093237d41e6ef9576412dbcc8575f (patch)
tree27248654250a5c60485c70ee403aa739bd6a02e6 /dev-python/psutil/psutil-5.7.0.ebuild
parentdev-libs/qtkeychain: keyword on ~ppc64 (diff)
downloadgentoo-d20080f1b85093237d41e6ef9576412dbcc8575f.tar.gz
gentoo-d20080f1b85093237d41e6ef9576412dbcc8575f.tar.bz2
gentoo-d20080f1b85093237d41e6ef9576412dbcc8575f.zip
dev-python/psutil: Bump to 5.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psutil/psutil-5.7.0.ebuild')
-rw-r--r--dev-python/psutil/psutil-5.7.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/psutil/psutil-5.7.0.ebuild b/dev-python/psutil/psutil-5.7.0.ebuild
new file mode 100644
index 000000000000..7940191f1b91
--- /dev/null
+++ b/dev-python/psutil/psutil-5.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/ipaddress[${PYTHON_USEDEP}]
+ ' -2)
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/psutil-5.7.0-tests.patch"
+)
+
+python_test() {
+ if [[ ${EPYTHON} == pypy* ]]; then
+ ewarn "Not running tests on ${EPYTHON} since they are broken"
+ return 0
+ fi
+
+ # since we are running in an environment a bit similar to CI,
+ # let's skip the tests that are disable for CI
+ TRAVIS=1 APPVEYOR=1 "${EPYTHON}" psutil/tests/runner.py ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_compile() {
+ # force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}