summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 17:46:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 18:43:34 +0200
commit1a22d0a9c57689f96eef49fed4adc7de636573e5 (patch)
treeb38c0448950b35f0a3c2b75bdf52ef8d116c98d1 /dev-python/psutil/psutil-5.7.3.ebuild
parentdev-libs/libedit: set QA_PKGCONFIG_VERSION (diff)
downloadgentoo-1a22d0a9c57689f96eef49fed4adc7de636573e5.tar.gz
gentoo-1a22d0a9c57689f96eef49fed4adc7de636573e5.tar.bz2
gentoo-1a22d0a9c57689f96eef49fed4adc7de636573e5.zip
dev-python/psutil: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psutil/psutil-5.7.3.ebuild')
-rw-r--r--dev-python/psutil/psutil-5.7.3.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/psutil/psutil-5.7.3.ebuild b/dev-python/psutil/psutil-5.7.3.ebuild
deleted file mode 100644
index ddf8240254b4..000000000000
--- a/dev-python/psutil/psutil-5.7.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/psutil-5.7.2-tests.patch"
-)
-
-python_test() {
- if [[ ${EPYTHON} == pypy* ]]; then
- ewarn "Not running tests on ${EPYTHON} since they are broken"
- return 0
- fi
-
- # since we are running in an environment a bit similar to CI,
- # let's skip the tests that are disable for CI
- TRAVIS=1 APPVEYOR=1 "${EPYTHON}" psutil/tests/runner.py ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_compile() {
- # force -j1 to avoid .o linking race conditions
- local MAKEOPTS=-j1
- distutils-r1_python_compile
-}