summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-08-14 11:12:45 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-08-14 11:12:45 -0400
commit99f1cdfe5844734d98cb86ef81e25da7ac59812b (patch)
tree9e38ad7ae1e0a793845439ba04edaf7c55d4fe6e /dev-python/psycopg/psycopg-2.5.3.ebuild
parentdev-vcs/fossil: Bump to 2.6 (diff)
downloadgentoo-99f1cdfe5844734d98cb86ef81e25da7ac59812b.tar.gz
gentoo-99f1cdfe5844734d98cb86ef81e25da7ac59812b.tar.bz2
gentoo-99f1cdfe5844734d98cb86ef81e25da7ac59812b.zip
dev-python/psycopg: Cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/psycopg/psycopg-2.5.3.ebuild')
-rw-r--r--dev-python/psycopg/psycopg-2.5.3.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/psycopg/psycopg-2.5.3.ebuild b/dev-python/psycopg/psycopg-2.5.3.ebuild
deleted file mode 100644
index ac8962ba17d1..000000000000
--- a/dev-python/psycopg/psycopg-2.5.3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="http://initd.org/psycopg/ https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="debug doc examples"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile() {
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-
- [[ ${EPYTHON} != python3* ]] && append-flags -fno-strict-aliasing
-
- distutils-r1_python_compile
-}
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-2.4.2-setup.py.patch"
- )
-
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc -j1 html text
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodoc doc/{HACKING,SUCCESS}
-
- if use doc; then
- dodoc doc/psycopg2.txt
- dohtml -r doc/html/.
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/.
- fi
-}