summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-20 12:02:19 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 15:40:24 +0200
commit234c836cefdb52a1a2abcc3cb2e603ca84f1a7e2 (patch)
tree4b6c4b81f0e5c5106f1dc86f45ec8aa5c59cd9a9 /dev-python/psycopg
parentdev-python/openpyxl: Add python3.5 support (diff)
downloadgentoo-234c836cefdb52a1a2abcc3cb2e603ca84f1a7e2.tar.gz
gentoo-234c836cefdb52a1a2abcc3cb2e603ca84f1a7e2.tar.bz2
gentoo-234c836cefdb52a1a2abcc3cb2e603ca84f1a7e2.zip
dev-python/psycopg: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/psycopg-2.6.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/psycopg/psycopg-2.6.1.ebuild b/dev-python/psycopg/psycopg-2.6.1.ebuild
index dffd1e64af87..68ac338af534 100644
--- a/dev-python/psycopg/psycopg-2.6.1.ebuild
+++ b/dev-python/psycopg/psycopg-2.6.1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1 flag-o-matic
@@ -21,8 +22,10 @@ IUSE="debug doc examples"
RDEPEND=">=dev-db/postgresql-8.1"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/python-docs-2.7.6-r1:2.7 )"
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7
+ )"
RESTRICT="test"
# Remove py3.2 entry from intersphinx setting