summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-29 11:10:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-29 11:16:21 +0200
commit1691890636893f91dfcb48e167137dfd9378d68b (patch)
tree862e114e6d3aed175615602af831f4e07edacc32 /dev-python/pudb
parentdev-python/urwid_readline: New dep of dev-python/pudb (diff)
downloadgentoo-1691890636893f91dfcb48e167137dfd9378d68b.tar.gz
gentoo-1691890636893f91dfcb48e167137dfd9378d68b.tar.bz2
gentoo-1691890636893f91dfcb48e167137dfd9378d68b.zip
dev-python/pudb: Bump to 2021.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/Manifest1
-rw-r--r--dev-python/pudb/pudb-2021.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pudb/Manifest b/dev-python/pudb/Manifest
index 84ab9915352a..e65dc10a3dc1 100644
--- a/dev-python/pudb/Manifest
+++ b/dev-python/pudb/Manifest
@@ -1 +1,2 @@
DIST pudb-2021.1.tar.gz 216707 BLAKE2B 1287fa48607e9b73dd0bed063b29933dd4de6ab598ad99217ab13a719a6b9654765bc44c28150962ba22703733a4e956c39e843414444c3b7fff67cefe70d7d8 SHA512 54d62f1342ab461e58a382c0eb654ecc9d3bd759844bab2f0a339e91ba805670e4dc7ccd84e8188f34e06a07ac770f1c0cddd4a4ef916885af0bdc638db81fcf
+DIST pudb-2021.2.tar.gz 216306 BLAKE2B a3c4fce5515e49851ac0e2ec73aa4364d3311dbd64060181198315ec0aeeb860d95f34d09004a86bb73269252362a966e541547d19c6db74ffd51a0535a0942c SHA512 f6d07b752268115b8e833e5aac5e5984e77beaf02fd7d2ab91e0b94c61f4c32d639f4ed75d262e66526c00bec03c6c3cefb92d77d8bdb330eb5cb73f9bec009c
diff --git a/dev-python/pudb/pudb-2021.2.ebuild b/dev-python/pudb/pudb-2021.2.ebuild
new file mode 100644
index 000000000000..caf71861de17
--- /dev/null
+++ b/dev-python/pudb/pudb-2021.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwid_readline[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest