summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-03-04 16:00:26 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-03-04 16:01:15 +0700
commit9f8761f9fa70e354d2032b381e734ce51a28be47 (patch)
tree1735aff88b9c614c799c944c1af75416b9aa0320 /dev-python/pudb
parentdev-python/tox: Bump to 3.23.0 (diff)
downloadgentoo-9f8761f9fa70e354d2032b381e734ce51a28be47.tar.gz
gentoo-9f8761f9fa70e354d2032b381e734ce51a28be47.tar.bz2
gentoo-9f8761f9fa70e354d2032b381e734ce51a28be47.zip
dev-python/pudb: bump to 2020.1
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pudb')
-rw-r--r--dev-python/pudb/Manifest1
-rw-r--r--dev-python/pudb/pudb-2020.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pudb/Manifest b/dev-python/pudb/Manifest
index dd96471dc72a..563bd9e2b9a4 100644
--- a/dev-python/pudb/Manifest
+++ b/dev-python/pudb/Manifest
@@ -1 +1,2 @@
DIST pudb-2019.2.tar.gz 59548 BLAKE2B 2df98688948ea79b8bbe125735aef04b3ea5d6db4adba503610c3fc88201cd0ae6da3249371f9ef78d1f4650901a02cc25738201e4891695f7726c919dcdd702 SHA512 231663b404e0e7d35f32235c02d4878b41a043054821c3d39d4a05d45c1e45aff0eaffb0a6d96669676b52538ca99a69de64014f922e3c80405d34198c6d4812
+DIST pudb-2020.1.tar.gz 70838 BLAKE2B c0f9ebf88851ebd859876e3e9b29239c72e308d7a544aee26baeb44a47ec3de75aed031ca10ef67c32d0262ffa690bfc063122524e64afa7d5763afb9a5baccf SHA512 4878c3f375d96130ca9a1afe668227b6f08e876e618bcffb47b1507be6bf7a393d88ab5f65f33c6497c98e645a188d5f3eaabb4f6a1e49d8d09b0f8b6b17ba14
diff --git a/dev-python/pudb/pudb-2020.1.ebuild b/dev-python/pudb/pudb-2020.1.ebuild
new file mode 100644
index 000000000000..f3ba56f54e5a
--- /dev/null
+++ b/dev-python/pudb/pudb-2020.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A full-screen, console-based Python debugger"
+HOMEPAGE="https://pypi.org/project/pudb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"