summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:09 +0200
commitaad5b11056a9d3fae8120b608da6fabdc0601f9e (patch)
tree73779aa946535a0a81a7ff5e7f419a45e59be1cc /dev-python/pushbullet-py
parentdev-python/pudb: Remove redundant versions (diff)
downloadgentoo-aad5b11056a9d3fae8120b608da6fabdc0601f9e.tar.gz
gentoo-aad5b11056a9d3fae8120b608da6fabdc0601f9e.tar.bz2
gentoo-aad5b11056a9d3fae8120b608da6fabdc0601f9e.zip
dev-python/pushbullet-py: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pushbullet-py')
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild
deleted file mode 100644
index 267422432286..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.11.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="https://github.com/randomchars/pushbullet.py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- # skip tests which require network access
- PUSHBULLET_API_KEY= py.test \
- -k "not (test_auth or test_decryption)" \
- || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}