summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-17 13:38:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-17 17:55:46 +0100
commit3983305866387caa0cdd206d3732effbdbea93c9 (patch)
treec131d949cafdc6661e36e6ff7a26872e1fd8da67 /dev-python/py-ubjson
parentdev-python/aiohttp-cors: Fix test deps (diff)
downloadgentoo-3983305866387caa0cdd206d3732effbdbea93c9.tar.gz
gentoo-3983305866387caa0cdd206d3732effbdbea93c9.tar.bz2
gentoo-3983305866387caa0cdd206d3732effbdbea93c9.zip
dev-python/py-ubjson: Bump to 0.15.0, tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py-ubjson')
-rw-r--r--dev-python/py-ubjson/Manifest1
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.15.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/py-ubjson/Manifest b/dev-python/py-ubjson/Manifest
index 1d923e88348c..a9a4ed703e03 100644
--- a/dev-python/py-ubjson/Manifest
+++ b/dev-python/py-ubjson/Manifest
@@ -1,3 +1,4 @@
DIST py-ubjson-0.10.0.tar.gz 44653 BLAKE2B 91c40aab4cc66200d863fb13e4f0b64f4b1903422732f83af1f32d05a7e002723bb101b085c3d34bd33c0f2c161e24877b8fe8e8d7c09a54bac043104a58ceb1 SHA512 f4fd5dedf0212d91d8fc65b4379ccdd2576d6a3e4f5200f0f6caebd4671d582516916fc89af5d942c35624a98ac76db8fe0825a269206de4ab1ca63b54608cc2
DIST py-ubjson-0.11.0.tar.gz 45473 BLAKE2B b74bfc20b30a2a45fb4511aa730d51245e6810fb8b00980dd61ae5bfa7cda1f60397de8c9d914195dffc48e4ec9582f839b9e133b98dd897b0a47a03abfbb67d SHA512 2c5dd111ea91fff1cebd722c62b312422e198bb8cc614e1254a3913067f72124efd1cd9879bd83ff88c2fc12ff2ef17fcf350ef7a3d6587c96a58c8b9e8ca547
+DIST py-ubjson-0.15.0.tar.gz 50111 BLAKE2B e4f248935778f7d0802b5bace155409e47609b18fa21792a8eb16ef24e3ee2eb59d143b039994b4342bb47c20da4539f4d83307f4afb4aeced5c238ea6c7f7cb SHA512 daeb50dfdccf1479a62ad653aaa37cdb0784ff22397e466f7a9af42a1af3165ddd11308b0d8917b96d8a8d4b87040d0789b28223838df826e953acb2e59d3a1c
DIST py-ubjson-0.9.0.tar.gz 43338 BLAKE2B 8bcf61d1329931a2bfb7399cc27e72b14f9641fe902f0275ae190b1b256c67d78fe9b436aacf6b33912ef0e29a008e4e7b05a12b10488714ecb5b31451c1e69e SHA512 d9f061e548405d16a22d235f487740b3d4abeab8b555f9684b632cdb5e2f655ba8413a207230f90e7f3f352fa3289b16bb9a56b623c0cc5fe02f61778a8f78a2
diff --git a/dev-python/py-ubjson/py-ubjson-0.15.0.ebuild b/dev-python/py-ubjson/py-ubjson-0.15.0.ebuild
new file mode 100644
index 000000000000..5afc56e7348d
--- /dev/null
+++ b/dev-python/py-ubjson/py-ubjson-0.15.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Binary JSON encoder/decoder"
+HOMEPAGE="https://github.com/Iotic-Labs/py-ubjson https://pypi.org/project/py-ubjson/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # to make unittest happy
+ touch test/__init__.py || die
+ distutils-r1_src_prepare
+}