summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyacoustid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/Manifest1
-rw-r--r--dev-python/pyacoustid/metadata.xml13
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
new file mode 100644
index 000000000000..b91c2838eb35
--- /dev/null
+++ b/dev-python/pyacoustid/Manifest
@@ -0,0 +1 @@
+DIST pyacoustid-1.0.0.tar.gz 10476 SHA256 31900428e7b344dca0c2da594b387e88620c319298e3a6400a968078194407d4 SHA512 4eabf32e7d958bf7330e852184f5ddf3105007179ca2c45b75c1a5b0f0898649e703aa333cffccac85eb7b18b54255f2e5d588897adfb9f0ef2596e9c0b2fe5a WHIRLPOOL 084bc175021db2b344484fa5f03bf8b63b78ba21f92e050da93d36dcded494ff62f6344f59f8f0027b8b42a4bb6a1d21d22408a4f5679023c10eb37907ab1b79
diff --git a/dev-python/pyacoustid/metadata.xml b/dev-python/pyacoustid/metadata.xml
new file mode 100644
index 000000000000..dabddb714014
--- /dev/null
+++ b/dev-python/pyacoustid/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+Chromaprint and its associated Acoustid Web service make up a high-quality, open-source acoustic fingerprinting system. This package provides Python bindings for both the fingerprinting algorithm library, which is written in C but portable, and the Web service, which provides fingerprint lookups.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyacoustid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..8c88432bbe6a
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for Chromaprint acoustic fingerprinting and the Acoustid API"
+HOMEPAGE="http://pypi.python.org/pypi/pyacoustid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="media-libs/chromaprint
+ dev-python/audioread[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./aidmatch.py)
+ distutils-r1_python_install_all
+}