summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-03-18 10:05:36 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-03-18 10:05:52 -0400
commitdeada4b58718bc0b414298975df9c198dbb95541 (patch)
treea061ee32c550040359eaf6a87be6346162cccff8 /dev-python/pyaes/pyaes-1.6.0.ebuild
parentx11-misc/treeline: Version bump. (diff)
downloadgentoo-deada4b58718bc0b414298975df9c198dbb95541.tar.gz
gentoo-deada4b58718bc0b414298975df9c198dbb95541.tar.bz2
gentoo-deada4b58718bc0b414298975df9c198dbb95541.zip
dev-python/pyaes: Initial commit. Needed for net-misc/electrum, bug #612706
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pyaes/pyaes-1.6.0.ebuild')
-rw-r--r--dev-python/pyaes/pyaes-1.6.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyaes/pyaes-1.6.0.ebuild b/dev-python/pyaes/pyaes-1.6.0.ebuild
new file mode 100644
index 000000000000..a318c326068d
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.python.org/pypi/pyaes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPENDS="dev-python/setuptools"
+
+#S=${WORKDIR}/${MY_P}