summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch')
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch b/dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch
new file mode 100644
index 000000000000..72bf0bcb49c5
--- /dev/null
+++ b/dev-python/pyalsa/files/pyalsa-1.0.29-no-build-symlinks.patch
@@ -0,0 +1,24 @@
+diff -ur pyalsa-1.0.29.orig/setup.py pyalsa-1.0.29/setup.py
+--- setup.py 2015-02-26 20:36:18.000000000 +0800
++++ setup.py 2015-03-22 12:53:26.941401236 +0800
+@@ -58,20 +58,3 @@
+ packages=['pyalsa'],
+ scripts=[]
+ )
+-
+-uname = os.uname()
+-a = 'build/lib.%s-%s-%s' % (uname[0].lower(), uname[4], sys.version[:3])
+-for f in ['alsacard.so', 'alsacontrol.so', 'alsahcontrol.so',
+- 'alsamixer.so', 'alsaseq.so']:
+- if not os.path.exists('pyalsa/%s' % f):
+- a = '../build/lib.%s-%s-%s/pyalsa/%s' % \
+- (uname[0].lower(), uname[4], sys.version[:3], f)
+- print a, f
+- p = 'pyalsa/' + f
+- try:
+- st = os.lstat(p)
+- if stat.S_ISLNK(st.st_mode):
+- os.remove(p)
+- except:
+- pass
+- os.symlink(a, 'pyalsa/%s' % f)