summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-06 16:12:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-06 17:22:23 +0100
commit64cbbe6b36a8693d5af93af00732318bfe0b6c25 (patch)
tree98ef6e10cff3cf1e540d3c4b181c5c173d06a292 /dev-python/pyamg/pyamg-2.2.1.ebuild
parentsci-libs/scikits_learn: Version Bump (diff)
downloadgentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.tar.gz
gentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.tar.bz2
gentoo-64cbbe6b36a8693d5af93af00732318bfe0b6c25.zip
dev-python/pyamg: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyamg/pyamg-2.2.1.ebuild')
-rw-r--r--dev-python/pyamg/pyamg-2.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyamg/pyamg-2.2.1.ebuild b/dev-python/pyamg/pyamg-2.2.1.ebuild
new file mode 100644
index 000000000000..bcfdd108f5ea
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://pyamg.github.io/ https://github.com/pyamg/pyamg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${T}" || die # need to be away source directory
+ "${PYTHON}" "${S}"/test_pyamg_install.py || die
+}