summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-27 12:29:30 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-27 12:29:30 +0200
commit24f31b10dcaaafe78035d79bdf16decb022a69bf (patch)
treeec405c5617cda3af7567f06252731bc1bdaaca17 /dev-python/pyamg
parentdev-python/sphinx-panels: enable py3.10 (diff)
downloadgentoo-24f31b10dcaaafe78035d79bdf16decb022a69bf.tar.gz
gentoo-24f31b10dcaaafe78035d79bdf16decb022a69bf.tar.bz2
gentoo-24f31b10dcaaafe78035d79bdf16decb022a69bf.zip
dev-python/pyamg: add version 4.1.0, enable py3.10
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyamg')
-rw-r--r--dev-python/pyamg/Manifest1
-rw-r--r--dev-python/pyamg/pyamg-4.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
index a1a195d67593..8c133042a3f8 100644
--- a/dev-python/pyamg/Manifest
+++ b/dev-python/pyamg/Manifest
@@ -1 +1,2 @@
DIST pyamg-4.0.0.tar.gz 717171 BLAKE2B 16483d829e8a938359827ca8ebe3093c890685244125576e05220910b66e9aeec278472134d10c589e58dfbd363930cdd7ae13d16c9b9d54c1bd5250e66f4677 SHA512 cdd27834c12ef18f023e78b5b946c06bc2c35f73cf65fc4c76da2fab75f23466e6c1a4b3dccb8506be3ada7e0bafda38122d3d7315deebc7959d2e5300d9add1
+DIST pyamg-4.1.0.tar.gz 749906 BLAKE2B 31c05d64317b32cbdbd616e982557f0a94bc17b2fce3d982fe93e629d56ad526516603032b3cba9785bf5ebed038481ae641f55a5a1ad621442dde08791981cb SHA512 311642cbbe8dca621cb58bebb1bb05b7dc7b2364713886df96937ba56575137bcb4fb7006a232d2c14380cd41f4337f6f09a8a9794e279a155f27287497d2b08
diff --git a/dev-python/pyamg/pyamg-4.1.0.ebuild b/dev-python/pyamg/pyamg-4.1.0.ebuild
new file mode 100644
index 000000000000..27080fa711fe
--- /dev/null
+++ b/dev-python/pyamg/pyamg-4.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="https://pyamg.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+# cannot be enabled by "distutils_enable_tests pytest"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0.0-test.patch )