summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyamg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyamg')
-rw-r--r--dev-python/pyamg/Manifest1
-rw-r--r--dev-python/pyamg/files/2.0.0-stencil.patch11
-rw-r--r--dev-python/pyamg/files/pyamg-2.0.4-gcc-4.7.patch16
-rw-r--r--dev-python/pyamg/metadata.xml14
-rw-r--r--dev-python/pyamg/pyamg-2.1.0.ebuild30
5 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
new file mode 100644
index 000000000000..6bf901647e5c
--- /dev/null
+++ b/dev-python/pyamg/Manifest
@@ -0,0 +1 @@
+DIST pyamg-2.1.0.tar.gz 752632 SHA256 060a32ea8805b8e49e6d7304ab771efccd34d5e363a65f4f2cb33d85981225de SHA512 d2574ccb093e6c5bd214c4366ec70bfeae73449f98932a9a4435afb2d606b12a4d479411a88bcac4df500e33dbf635ae981620c584e688abc3f2cca6c6188d4d WHIRLPOOL ccf0817561eae43bb859aaedc9c7b4c94e338a2fc6817467bb5f162df3e63720030d3e36d55e72e9f7e613aab89cf4211f9c20fc97d566e3d7cdec988c9d9f6f
diff --git a/dev-python/pyamg/files/2.0.0-stencil.patch b/dev-python/pyamg/files/2.0.0-stencil.patch
new file mode 100644
index 000000000000..f000b93709ac
--- /dev/null
+++ b/dev-python/pyamg/files/2.0.0-stencil.patch
@@ -0,0 +1,11 @@
+--- pyamg/gallery/stencil.py.orig 2011-08-06 20:26:36.000000000 +0100
++++ pyamg/gallery/stencil.py 2011-08-06 20:27:12.000000000 +0100
+@@ -85,7 +85,7 @@
+
+ # compute index offset of each dof within the stencil
+ strides = numpy.cumprod( [1] + list(reversed(grid)) )[:-1]
+- indices = S.nonzero()
++ indices = tuple(i.copy() for i in S.nonzero())
+ for i,s in zip(indices,S.shape):
+ i -= s // 2
+ for stride,coords in zip(strides, reversed(indices)):
diff --git a/dev-python/pyamg/files/pyamg-2.0.4-gcc-4.7.patch b/dev-python/pyamg/files/pyamg-2.0.4-gcc-4.7.patch
new file mode 100644
index 000000000000..0ed5402b7e48
--- /dev/null
+++ b/dev-python/pyamg/files/pyamg-2.0.4-gcc-4.7.patch
@@ -0,0 +1,16 @@
+ pyamg/amg_core/ruge_stuben.h | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/pyamg/amg_core/ruge_stuben.h b/pyamg/amg_core/ruge_stuben.h
+index 51cec80..d0ff9a9 100644
+--- a/pyamg/amg_core/ruge_stuben.h
++++ b/pyamg/amg_core/ruge_stuben.h
+@@ -7,6 +7,8 @@
+ #include <cassert>
+ #include <limits>
+ #include <algorithm>
++#include "graph.h"
++#include "linalg.h"
+
+ /*
+ * Compute a strength of connection matrix using the classical strength
diff --git a/dev-python/pyamg/metadata.xml b/dev-python/pyamg/metadata.xml
new file mode 100644
index 000000000000..106c66bc219b
--- /dev/null
+++ b/dev-python/pyamg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ PyAMG is a library of Algebraic Multigrid (AMG) solvers with a
+ Python interface.
+ The predominant portion of PyAMG is written in Python with a smaller
+ amount of supporting C++ code for performance critical operations.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">pyamg</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pyamg/pyamg-2.1.0.ebuild b/dev-python/pyamg/pyamg-2.1.0.ebuild
new file mode 100644
index 000000000000..6a4d7d4a0fe6
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://pyamg.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ distutils_install_for_testing
+ cd "${T}" || die # need to be away source directory
+ ${EPYTHON} -c "
+import pyamg, sys
+r = pyamg.test(verbose=3)
+sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
+}