summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 17:20:09 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 18:14:48 +0100
commit620b91fd054274c0935afd96f31292466e3ec698 (patch)
tree7a36051c4b1fcfb2a7cc3fc1ad972a72c75c0c29 /dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
parentdev-python/pyshark: Add py3 support (diff)
downloadgentoo-620b91fd054274c0935afd96f31292466e3ec698.tar.gz
gentoo-620b91fd054274c0935afd96f31292466e3ec698.tar.bz2
gentoo-620b91fd054274c0935afd96f31292466e3ec698.zip
dev-python/pyasn1-modules: Fix tests
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=570742 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild')
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
index 9b06f54c4400..063ce707be18 100644
--- a/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,9 +24,9 @@ DEPEND="${RDEPEND}
python_test() {
echoit() { echo "$@"; "$@"; }
local exit_status=0 test
- for test in test/*.sh; do
- PATH="${S}/tools:${PATH}" \
- echoit sh "${test}" || exit_status=1
+ cd tools || die
+ for test in ../test/*.sh; do
+ echoit sh "${test}" || exit_status=1
done
return ${exit_status}
}