summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyasn1
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyasn1')
-rw-r--r--dev-python/pyasn1/Manifest2
-rw-r--r--dev-python/pyasn1/metadata.xml8
-rw-r--r--dev-python/pyasn1/pyasn1-0.1.7.ebuild32
-rw-r--r--dev-python/pyasn1/pyasn1-0.1.8.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
new file mode 100644
index 000000000000..34c72dce1b81
--- /dev/null
+++ b/dev-python/pyasn1/Manifest
@@ -0,0 +1,2 @@
+DIST pyasn1-0.1.7.tar.gz 68120 SHA256 e4f81d53c533f6bd9526b047f047f7b101c24ab17339c1a7ad8f98b25c101eab SHA512 af2ac05fb7e18b25bd125f92bd7c8389a00c18018c1ff48d94c196f5ab41b09c8991d2e326d492cfaed755b06cd4c75d88719b4a390bdab6d84fe3c8791620af WHIRLPOOL 902b80616cecbf3549417c95ec09c060c6a038f95bd71ce2f9a5c0cd1e4cfd4e9157252abedec3002588eaba5a3cecd7100138c952a5e8f8b7e245b4f82d5c7c
+DIST pyasn1-0.1.8.tar.gz 75676 SHA256 5d33be7ca0ec5997d76d29ea4c33b65c00c0231407fff975199d7f40530b8347 SHA512 0a0b9b8018ae80a0e0d84ea3a4f217951bf42dce909a354c97890d4b4fc4f49b19d9d0757103ac9002c17c6c622c8e8d66e1f8242b8545a7da455ef3583acdfa WHIRLPOOL db46e06ef9a6b5858c07f1c154657f998b509c457395b4f2e6286ea90e1b16346e24d92a8d666b5db4216e35129f2d6be13c2fc11aae2d9936163bff3b1400eb
diff --git a/dev-python/pyasn1/metadata.xml b/dev-python/pyasn1/metadata.xml
new file mode 100644
index 000000000000..fcab60fb450b
--- /dev/null
+++ b/dev-python/pyasn1/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyasn1</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyasn1/pyasn1-0.1.7.ebuild b/dev-python/pyasn1/pyasn1-0.1.7.ebuild
new file mode 100644
index 000000000000..68a91358d0e5
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ http://pypi.python.org/pypi/pyasn1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test/suite.py || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ local HTML_DOCS=( doc/pyasn1-tutorial.html )
+ use doc && HTML_DOCS=( doc/. )
+
+ distutils-r1_src_install
+}
diff --git a/dev-python/pyasn1/pyasn1-0.1.8.ebuild b/dev-python/pyasn1/pyasn1-0.1.8.ebuild
new file mode 100644
index 000000000000..eaf95f140a95
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ http://pypi.python.org/pypi/pyasn1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test/suite.py || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ local HTML_DOCS=( doc/pyasn1-tutorial.html )
+ use doc && HTML_DOCS=( doc/. )
+
+ distutils-r1_src_install
+}