summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-08 09:43:20 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 10:45:19 +0300
commiteac5ef080662ac6b4b073c8dec6c0f41633f9318 (patch)
treec26964ab57685a3bd8039df1bee905a4b865945c /dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
parentdev-python/pyaudio: bump EAPI 7, use distutils to install docs (diff)
downloadgentoo-eac5ef080662ac6b4b073c8dec6c0f41633f9318.tar.gz
gentoo-eac5ef080662ac6b4b073c8dec6c0f41633f9318.tar.bz2
gentoo-eac5ef080662ac6b4b073c8dec6c0f41633f9318.zip
dev-python/pyaudio: restirct tests, and explain why so
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild')
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild b/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
index 90922f58adea..ec8e831d71f5 100644
--- a/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
+++ b/dev-python/pyaudio/pyaudio-0.2.11-r1.ebuild
@@ -16,7 +16,9 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+
+# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
+RESTRICT="test"
RDEPEND="media-libs/portaudio"
DEPEND="${RDEPEND}
@@ -26,6 +28,10 @@ distutils_enable_sphinx sphinx
distutils_enable_tests unittest
python_test() {
+ elog "These tests require an OS loopback sound device that forwards audio"
+ elog "output, generated by PyAudio for playback, and forwards it to an input"
+ elog "device, which PyAudio can record and verify against a test signal."
+
cd tests || die
# pyaudio_tests have very complicated runtime requirements, therefore skipping them.
"${EPYTHON}" -m unittest error_tests -v ||