summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-06-03 15:19:30 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-03 15:20:01 -0400
commit079a605885d08aa1bfaa8a952eb0491a0253f106 (patch)
tree1805c6bca5331cee0a417619d99b556bfb8f2698 /dev-python/pybind11/pybind11-2.5.0.ebuild
parentdev-libs/libudfread: Cleanup old version (diff)
downloadgentoo-079a605885d08aa1bfaa8a952eb0491a0253f106.tar.gz
gentoo-079a605885d08aa1bfaa8a952eb0491a0253f106.tar.bz2
gentoo-079a605885d08aa1bfaa8a952eb0491a0253f106.zip
dev-python/pybind11: dep fixup
dep fixup reported by waebbl I tried to fix tests by gave up I hate the doc handling but I don't know how to do better Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pybind11/pybind11-2.5.0.ebuild')
-rw-r--r--dev-python/pybind11/pybind11-2.5.0.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-python/pybind11/pybind11-2.5.0.ebuild b/dev-python/pybind11/pybind11-2.5.0.ebuild
index 9f4ad379f84e..4cbab835b55a 100644
--- a/dev-python/pybind11/pybind11-2.5.0.ebuild
+++ b/dev-python/pybind11/pybind11-2.5.0.ebuild
@@ -14,13 +14,14 @@ SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
+IUSE="doc test"
DEPEND="
${PYTHON_DEPS}
doc? (
dev-python/breathe[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
+ <dev-python/sphinx-3[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
)
"
RDEPEND="
@@ -32,8 +33,11 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DOCS=( README.md CONTRIBUTING.md ISSUE_TEMPLATE.md )
+#I can't make tests do anything
+RESTRICT=test
+
pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python3_6' )
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python3_7' )
}
python_prepare_all() {
@@ -45,19 +49,19 @@ python_prepare_all() {
python_configure_all() {
local mycmakeargs=(
-DPYBIND11_INSTALL=ON
- -DPYBIND11_TEST=OFF
+ -DPYBIND11_TEST=$(usex test)
)
-
cmake_src_configure
}
python_compile_all() {
- # No compilation has to be done by cmake
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
# documentation is not covered by cmake, but has it's own makefile
# using sphinx
if use doc; then
- python_setup 'python3_6'
+ python_setup 'python3_7'
pushd "${S}"/docs || die
emake info man html
popd || die
@@ -77,3 +81,7 @@ python_install_all() {
distutils-r1_python_install_all
}
+
+python_test_all() {
+ cmake_src_test
+}