summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-10-27 15:43:50 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-10-27 15:44:12 -0700
commitc14c11f3004c28bc6b3e42563a82e02833ae27f6 (patch)
treed7df95979b9dc4789b8c6f5bcead24438dba169f /dev-python/pybind11
parentdev-libs/leveldb: Keyword 1.23-r1 sparc, #807025 (diff)
downloadgentoo-c14c11f3004c28bc6b3e42563a82e02833ae27f6.tar.gz
gentoo-c14c11f3004c28bc6b3e42563a82e02833ae27f6.tar.bz2
gentoo-c14c11f3004c28bc6b3e42563a82e02833ae27f6.zip
dev-python/pybind11: Version bump to 2.8.1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.8.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 8e6050c7d18a..f92ed463cb7e 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,2 +1,3 @@
DIST pybind11-2.7.1.tar.gz 668217 BLAKE2B 92d857f14290ee0717bd9f9b871dcecd6c0b36209bb9879f107c8542326fb0cc42c051f3bc12a8be50df892f1e26c26b710f60ed275f0dff206e30149547f2b4 SHA512 f09f46622b394d3990ab82aa7ea15a06e298df109cd2df263ba9d6ac7fb248217df7450e1954a9679a8360335d5bbf662926a34c8b7c61b6e4c396bbdfd88305
DIST pybind11-2.8.0.tar.gz 688544 BLAKE2B 3652ebf56cdec9c50a431915b4b59cd7c61d58be5a521dd2bea20ea9a0e56ae8782400d4460a5e32f3c3ec086709ee466b6b39c6adc5cd712da05b4016f9f2e1 SHA512 2f066ab1a3d4a22513625f52b55d7722f953007876e800b4a08d6341b9ae70f73a3b0fd57f76cee443e7b8cf0eecdaafc032a23ddad2b8bca2c8108ac4090a82
+DIST pybind11-2.8.1.tar.gz 693075 BLAKE2B 00f691121858bbe019b5398ab5418523b352f29716901ec6572817e3a35efeb953a9a1542ad37830aab6b9e5a6d6dd56c7aee390772f1d992ef570e03472ebd8 SHA512 6738b4551a1ca2fdf6676be78216b9056cecf8b4d125f0d1aaae9929614bcbf4a9b233fc3c52b8f9dfd19a9ca1496515e6748c1afd8968b9c52c9a1e8b28da10
diff --git a/dev-python/pybind11/pybind11-2.8.1.ebuild b/dev-python/pybind11/pybind11-2.8.1.ebuild
new file mode 100644
index 000000000000..3edf9adb8aa7
--- /dev/null
+++ b/dev-python/pybind11/pybind11-2.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
+SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ dev-cpp/eigen:3
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ export PYBIND11_USE_CMAKE=1
+
+ cmake_src_prepare
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ local mycmakeargs=(
+ # disable forced lto
+ -DPYBIND11_LTO_CXX_FLAGS=
+ -DPYBIND11_INSTALL=ON
+ -DPYBIND11_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ # Compilation only does anything for tests
+ use test && cmake_src_compile
+}
+
+python_test() {
+ cmake_build check
+}
+
+python_install() {
+ distutils-r1_python_install
+ cmake_src_install
+}