summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-02-18 10:05:38 -0500
committerRick Farina <zerochaos@gentoo.org>2020-02-18 10:06:16 -0500
commit17cadfd2c3c437bdc153cbbd8b2680b8f87b34d1 (patch)
tree3924cf9bd0f3aa789e65a044b08fe04c5859475e /dev-python/pybluez/pybluez-0.23.ebuild
parentsys-apps/systemd: update Manifest (diff)
downloadgentoo-17cadfd2c3c437bdc153cbbd8b2680b8f87b34d1.tar.gz
gentoo-17cadfd2c3c437bdc153cbbd8b2680b8f87b34d1.tar.bz2
gentoo-17cadfd2c3c437bdc153cbbd8b2680b8f87b34d1.zip
dev-python/pybluez: bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pybluez/pybluez-0.23.ebuild')
-rw-r--r--dev-python/pybluez/pybluez-0.23.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pybluez/pybluez-0.23.ebuild b/dev-python/pybluez/pybluez-0.23.ebuild
new file mode 100644
index 000000000000..7a47efc5362d
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.23.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="https://github.com/pybluez/pybluez"
+SRC_URI="mirror://pypi/P/PyBluez/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="net-wireless/bluez"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x usr/share/doc/${PF}/examples
+ fi
+}