summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-18 09:14:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-18 10:09:40 +0100
commit4318e033a5c07165f1e5df93afddc645981a3a26 (patch)
tree7b68b562900aa431de5fd6467a24d2586074dac5 /dev-python/pybtex
parentdev-python/latexcodec: Add py3.9 (diff)
downloadgentoo-4318e033a5c07165f1e5df93afddc645981a3a26.tar.gz
gentoo-4318e033a5c07165f1e5df93afddc645981a3a26.tar.bz2
gentoo-4318e033a5c07165f1e5df93afddc645981a3a26.zip
dev-python/pybtex: Bump to 0.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pybtex')
-rw-r--r--dev-python/pybtex/Manifest1
-rw-r--r--dev-python/pybtex/pybtex-0.24.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pybtex/Manifest b/dev-python/pybtex/Manifest
index 73dd4e917c64..9b11087cfe74 100644
--- a/dev-python/pybtex/Manifest
+++ b/dev-python/pybtex/Manifest
@@ -1 +1,2 @@
DIST pybtex-0.23.0.tar.gz 400649 BLAKE2B ae841eb98588fea55dea59a90be4ea5489b115b5594aa2ba7da140d529371c9275d28896d2b3b1d7fdbfe6a4bc7f1a99a8a73505f5d141f7affc0f22e5b08ceb SHA512 11b4c8141f237a25c320726b18fb254df077f4b644ac26fa2bf9f3d85c4301ab839f3544a3c1849243e75bbcbf194b25642b0ef11d354e3711578a4e19565bde
+DIST pybtex-0.24.0.tar.gz 402879 BLAKE2B 0cbb74360ebb4e9598543b17a46f21fab037d83a50ee46eae50dd385b981789d72c8cfb0b6c9983a3721565cdefb0df7ca15c120683e33204c591863be79d23e SHA512 caa3480b82012d1db5e44ca7fb5a4082e9aa27e892364de22bd05b0b589da3b1bd41eacd3cda8f86ce567b32ab9a22765d2d8d89c21936d4149d4511349c556e
diff --git a/dev-python/pybtex/pybtex-0.24.0.ebuild b/dev-python/pybtex/pybtex-0.24.0.ebuild
new file mode 100644
index 000000000000..903359c1e9db
--- /dev/null
+++ b/dev-python/pybtex/pybtex-0.24.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="BibTeX-compatible bibliography processor"
+HOMEPAGE="https://pybtex.org https://pypi.org/project/pybtex/"
+SRC_URI="https://files.pythonhosted.org/packages/source/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/latexcodec[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${PN}-0.22.2-fix-test-installation.patch" )