summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-04-21 19:59:45 -0700
committerMatt Turner <mattst88@gentoo.org>2018-04-21 19:59:45 -0700
commit595a9eb01494906adc888f86abbc16cdc0762ce1 (patch)
tree5c9a9d20aa75ca658f587494adcf058af7c1e6f7 /dev-python/pycairo
parentdev-python/pycairo-1.16.3-r1: hppa stable, bug 652262 (diff)
downloadgentoo-595a9eb01494906adc888f86abbc16cdc0762ce1.tar.gz
gentoo-595a9eb01494906adc888f86abbc16cdc0762ce1.tar.bz2
gentoo-595a9eb01494906adc888f86abbc16cdc0762ce1.zip
dev-python/pycairo: Drop old version
Bug: https://bugs.gentoo.org/651300 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/pycairo')
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/pycairo-1.15.3.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index a7d868e40872..137e3a16855b 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1,2 +1 @@
-DIST pycairo-1.15.3.tar.gz 177056 BLAKE2B cba4a212c3537d5718a73742468444b01372902d86f88558cf63ab2ec1999dac036b349d84dff0bdcae5126998c5e921f05bab54b708a29ca2381b8d1371ac44 SHA512 1fc75d193eacb976f2e5a594aa07409a0f80ccb21921065c1794961143785eed48be1966d2d2d3e2d0428f9b4e956994dd851d21f3c3cb91fbc27b007a901ce8
DIST pycairo-1.16.3.tar.gz 188610 BLAKE2B 71034891bae636e23379a3fdc49c9163cff61183fe46c4027bbad3206e72255e60081dbc3cb02808d5c3840b618f6c12f8106ca5a08ddb226a65917ba2da390c SHA512 d60978f85eb0430f2038b0e7d0bce23602e8c180a7611eea424fd8bc3cdd8ce249af364abd0e77ab3b7ab439761721cba5c2398f51af2a89add3fb7fda8aa5db
diff --git a/dev-python/pycairo/pycairo-1.15.3.ebuild b/dev-python/pycairo/pycairo-1.15.3.ebuild
deleted file mode 100644
index 7866b76d519a..000000000000
--- a/dev-python/pycairo/pycairo-1.15.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the cairo library"
-HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
-SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test xcb"
-
-# Note: xpyb is used as the C header, not Python modules
-RDEPEND="
- >=x11-libs/cairo-1.13.1[svg,xcb?]
-"
-DEPEND="${RDEPEND}
- xcb? ( $(python_gen_cond_dep '>=x11-libs/xpyb-1.3' 'python2*') )
- doc? ( dev-python/sphinx )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Fix pkgconfig path
- sed -i -e "/libdir =/s:\"lib\":\"$(get_libdir)\":" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local enable_xpyb
- python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
-
- esetup.py build ${enable_xpyb}
-}
-
-python_compile_all() {
- use doc && emake -C docs
-}
-
-python_test() {
- local enable_xpyb
- python_is_python3 || enable_xpyb=$(usex xcb "--enable-xpyb" "")
-
- esetup.py test ${enable_xpyb}
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/. )
-
- if use examples; then
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}