summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-01 14:01:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-01 14:01:31 +0200
commitc762b56501276436455ba24b128e785201be353e (patch)
treed9a54f934bec35a3062a7b652a20f65ff1bd6418 /dev-python/pycapnp/pycapnp-0.6.1.ebuild
parentros-meta/bond_core: Bump to 1.8.0. (diff)
downloadgentoo-c762b56501276436455ba24b128e785201be353e.tar.gz
gentoo-c762b56501276436455ba24b128e785201be353e.tar.bz2
gentoo-c762b56501276436455ba24b128e785201be353e.zip
dev-python/pycapnp: bump to 0.6.1
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/pycapnp/pycapnp-0.6.1.ebuild')
-rw-r--r--dev-python/pycapnp/pycapnp-0.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycapnp/pycapnp-0.6.1.ebuild b/dev-python/pycapnp/pycapnp-0.6.1.ebuild
new file mode 100644
index 000000000000..dcc5d83d6f4c
--- /dev/null
+++ b/dev-python/pycapnp/pycapnp-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapping of the Cap'n Proto library"
+HOMEPAGE="http://jparyani.github.io/pycapnp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND=">=dev-libs/capnproto-0.6:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # regen cython files
+ rm -f capnp/lib/capnp.cpp || die
+}