summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-02-12 13:57:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-02-12 14:19:20 +0100
commit27fdf43791edbcbbbf6b762792a3d98efd5aad31 (patch)
tree2704805c3ad9d2292ed5dafacb5a73a85982c1b8 /dev-python/pycapnp/pycapnp-0.6.4.ebuild
parentapp-i18n/man-pages-fr: Drop old (diff)
downloadgentoo-27fdf43791edbcbbbf6b762792a3d98efd5aad31.tar.gz
gentoo-27fdf43791edbcbbbf6b762792a3d98efd5aad31.tar.bz2
gentoo-27fdf43791edbcbbbf6b762792a3d98efd5aad31.zip
dev-python/pycapnp: bump to 0.6.4
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/pycapnp/pycapnp-0.6.4.ebuild')
-rw-r--r--dev-python/pycapnp/pycapnp-0.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pycapnp/pycapnp-0.6.4.ebuild b/dev-python/pycapnp/pycapnp-0.6.4.ebuild
new file mode 100644
index 000000000000..2eb401e85b86
--- /dev/null
+++ b/dev-python/pycapnp/pycapnp-0.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapping of the Cap'n Proto library"
+HOMEPAGE="http://jparyani.github.io/pycapnp/ https://github.com/capnproto/pycapnp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND=">=dev-libs/capnproto-0.6:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/sdist.patch" )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # regen cython files
+ rm -f capnp/lib/capnp.cpp || die
+
+ # Need c++14 for capnp 0.7
+ sed -e 's/std=c++11/std=c++14/g' \
+ -i setup.py \
+ -i buildutils/detect.py \
+ -i capnp/*/* \
+ || die
+}