summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 18:34:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 18:53:41 +0200
commit8a923da7c50a872f520485f5f41c771a696f12a9 (patch)
tree38594893f92c960b0239b3b87611779d1d993873 /dev-python/pycdio/pycdio-0.20-r1.ebuild
parentmedia-sound/pnmixer: update metadata.xml (diff)
downloadgentoo-8a923da7c50a872f520485f5f41c771a696f12a9.tar.gz
gentoo-8a923da7c50a872f520485f5f41c771a696f12a9.tar.bz2
gentoo-8a923da7c50a872f520485f5f41c771a696f12a9.zip
dev-python/pycdio: Use append-cflags
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pycdio/pycdio-0.20-r1.ebuild')
-rw-r--r--dev-python/pycdio/pycdio-0.20-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pycdio/pycdio-0.20-r1.ebuild b/dev-python/pycdio/pycdio-0.20-r1.ebuild
index d7094c248fd0..5d6a6d47586f 100644
--- a/dev-python/pycdio/pycdio-0.20-r1.ebuild
+++ b/dev-python/pycdio/pycdio-0.20-r1.ebuild
@@ -3,9 +3,10 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
HOMEPAGE="http://savannah.gnu.org/projects/libcdio/ https://pypi.python.org/pypi/pycdio"
@@ -21,11 +22,10 @@ DEPEND="${RDEPEND}
dev-lang/swig
dev-python/setuptools[${PYTHON_USEDEP}]"
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
RESTRICT="test" # currently tests fail
python_prepare_all() {
+ append-cflags -fno-strict-aliasing
# Remove obsolete sys.path and adjust 'data' paths in examples.
sed -i \
-e "s:^sys.path.insert.*::" \