summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pycollada
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest1
-rw-r--r--dev-python/pycollada/metadata.xml8
-rw-r--r--dev-python/pycollada/pycollada-0.4.ebuild64
-rw-r--r--dev-python/pycollada/pycollada-9999.ebuild64
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
new file mode 100644
index 000000000000..f0de7041cf89
--- /dev/null
+++ b/dev-python/pycollada/Manifest
@@ -0,0 +1 @@
+DIST pycollada-0.4.tar.gz 519732 SHA256 62a69cce29759900cce0400dac8796d7210de1910dad4c60d4094248c7738121 SHA512 6e9569b858f2014aa08764d0bf328c8317b94edc91e99c2a7c97bf2355983555ea103012d6e6f197862cb3df113ca9263de18fc47edb3c60e74fa8e58b5ca8b0 WHIRLPOOL ce54dcb29cab7e1d97ac8c2eaa3718182373dfa79c7647c7c46f5a2afde88bf7832f98db4a89bdfb58964ccbab041787ac17a25dabc148e963e0739bac27780e
diff --git a/dev-python/pycollada/metadata.xml b/dev-python/pycollada/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/dev-python/pycollada/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pycollada/pycollada-0.4.ebuild b/dev-python/pycollada/pycollada-0.4.ebuild
new file mode 100644
index 000000000000..14aa43748cf7
--- /dev/null
+++ b/dev-python/pycollada/pycollada-0.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_MULTIPLE_ABI=1
+
+inherit distutils-r1
+
+DESCRIPTION="python library for reading and writing collada documents"
+HOMEPAGE="http://pycollada.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/python-dateutil )"
+RDEPEND="dev-python/numpy
+ dev-python/lxml
+ >=dev-python/python-dateutil-2.0"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc ; then
+ pushd docs
+ emake html
+ popd
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ pushd docs/_build/html
+ dohtml -r *
+ popd
+ fi
+
+ if use examples ; then
+ insinto /usr/share/${P}/
+ doins -r examples
+ fi
+
+ install_test_data() {
+ insinto $(python_get_sitedir)/collada/tests/
+ doins -r collada/tests/data
+ }
+ python_foreach_impl install_test_data
+}
+
+src_test() {
+ test_collada() {
+ for script in "${S}"/collada/tests/*.py ; do
+ PYTHONPATH="${S}" $EPYTHON "${script}"
+ done
+ }
+ python_foreach_impl test_collada
+}
diff --git a/dev-python/pycollada/pycollada-9999.ebuild b/dev-python/pycollada/pycollada-9999.ebuild
new file mode 100644
index 000000000000..94fcbe883a59
--- /dev/null
+++ b/dev-python/pycollada/pycollada-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_MULTIPLE_ABI=1
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="python library for reading and writing collada documents"
+HOMEPAGE="http://pycollada.github.com/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/python-dateutil )"
+RDEPEND="dev-python/numpy
+ dev-python/lxml
+ >=dev-python/python-dateutil-2.0"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc ; then
+ pushd docs
+ emake html
+ popd
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ pushd docs/_build/html
+ dohtml -r *
+ popd
+ fi
+
+ if use examples ; then
+ insinto /usr/share/${P}/
+ doins -r examples
+ fi
+
+ install_test_data() {
+ insinto $(python_get_sitedir)/collada/tests/
+ doins -r collada/tests/data
+ }
+ python_foreach_impl install_test_data
+}
+
+src_test() {
+ test_collada() {
+ for script in "${S}"/collada/tests/*.py ; do
+ PYTHONPATH="${S}" $EPYTHON "${script}"
+ done
+ }
+ python_foreach_impl test_collada
+}