summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-13 08:36:01 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-13 10:37:32 +0100
commitdd06e2c0ccb69d87c3384c0fc696b980f4baf1dd (patch)
treeb3a0153bbd6897babf5f0c5b8a040420e5e8de98 /dev-python/pycollada
parentdev-python/sphinx-gallery: Bump to 0.10.1 (diff)
downloadgentoo-dd06e2c0ccb69d87c3384c0fc696b980f4baf1dd.tar.gz
gentoo-dd06e2c0ccb69d87c3384c0fc696b980f4baf1dd.tar.bz2
gentoo-dd06e2c0ccb69d87c3384c0fc696b980f4baf1dd.zip
dev-python/pycollada: Bump to 0.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest1
-rw-r--r--dev-python/pycollada/pycollada-0.7.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
index 3ba357d17709..f76004ad45f2 100644
--- a/dev-python/pycollada/Manifest
+++ b/dev-python/pycollada/Manifest
@@ -1 +1,2 @@
DIST pycollada-0.7.1.tar.gz 3526373 BLAKE2B 9adcbff206bc856fce1eef1784734c5604800cff350d32a83d53a4eaf965673adac797f510662dffc70fcfd76a7102fdb9321ead89d765954ffccc9338df446a SHA512 ac4d88b2398bf0364beaaf3e2e468be9131dc0f8088bfce8be18d9eb5a7c093db84a364931884fa7c493dfae81036ec63bc7c689ebf49e961eefc0c4853a0131
+DIST pycollada-0.7.2.tar.gz 3526845 BLAKE2B 3d8b4d2478fa4937756db69afbd8716ccd2dd4e0bec8e7dc045e84f06573605c0872d31bdee3d6ccca4b800699746877530f2fa81b5790c3f5c0cb3e7583fa66 SHA512 5c21155d52d54de62d192d4da0385bc7110ddd3962fe3e0e9e5904bbcd0e66cb1a95765c9996cdc5beef0edb30ee2123ae23b904d029be1c119e902d2fc4e7fe
diff --git a/dev-python/pycollada/pycollada-0.7.2.ebuild b/dev-python/pycollada/pycollada-0.7.2.ebuild
new file mode 100644
index 000000000000..d219b4090d8f
--- /dev/null
+++ b/dev-python/pycollada/pycollada-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing COLLADA documents"
+HOMEPAGE="https://pycollada.readthedocs.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.md COPYING README.markdown )
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples ; then
+ insinto /usr/share/${PF}/
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # ensure data files for tests are getting installed too
+ python_moduleinto collada/tests/
+ python_domodule collada/tests/data
+}