summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-19 04:09:44 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-19 04:19:41 -0400
commit4c6b2aeae060091407e8e8bfaff191a3e363a585 (patch)
tree4363f4fe7fe709f66b9421ab21f1e9b5a04d0ada /dev-python/pycountry/pycountry-17.9.23.ebuild
parentdev-python/pyserial: version bump to 3.4 (diff)
downloadgentoo-4c6b2aeae060091407e8e8bfaff191a3e363a585.tar.gz
gentoo-4c6b2aeae060091407e8e8bfaff191a3e363a585.tar.bz2
gentoo-4c6b2aeae060091407e8e8bfaff191a3e363a585.zip
dev-python/pycountry: version bump to 17.9.23
Diffstat (limited to 'dev-python/pycountry/pycountry-17.9.23.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-17.9.23.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-17.9.23.ebuild b/dev-python/pycountry/pycountry-17.9.23.ebuild
new file mode 100644
index 000000000000..5ab90f36de86
--- /dev/null
+++ b/dev-python/pycountry/pycountry-17.9.23.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}