summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-25 09:41:01 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-25 10:08:55 +0100
commitfabd76609d23df81f0d3c8fc0c0bebfb8fba7d7c (patch)
treead30e8875d54e44adc1e7c636913b75fd396665f /dev-python/pycparser/pycparser-2.19.ebuild
parentdev-python/pycparser: Drop old (diff)
downloadgentoo-fabd76609d23df81f0d3c8fc0c0bebfb8fba7d7c.tar.gz
gentoo-fabd76609d23df81f0d3c8fc0c0bebfb8fba7d7c.tar.bz2
gentoo-fabd76609d23df81f0d3c8fc0c0bebfb8fba7d7c.zip
dev-python/pycparser: Bump to 2.19 (bugfix)
Closes: https://bugs.gentoo.org/671830 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycparser/pycparser-2.19.ebuild')
-rw-r--r--dev-python/pycparser/pycparser-2.19.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.19.ebuild b/dev-python/pycparser/pycparser-2.19.ebuild
new file mode 100644
index 000000000000..238e14f63875
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.19.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://github.com/eliben/pycparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # note: tables built by py3.5+ are incompatible with older versions
+ # because of 100 group limit of 're' module -- just generate them
+ # separately optimized for each target instead
+ pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
+ "${PYTHON}" _build_tables.py || die
+ popd > /dev/null || die
+}
+
+python_test() {
+ # change workdir to avoid '.' import
+ nosetests -v -w tests || die
+}