summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/pycparser
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/pycparser-2.14-r1.ebuild34
-rw-r--r--dev-python/pycparser/pycparser-2.14.ebuild4
2 files changed, 2 insertions, 36 deletions
diff --git a/dev-python/pycparser/pycparser-2.14-r1.ebuild b/dev-python/pycparser/pycparser-2.14-r1.ebuild
deleted file mode 100644
index d479b06b7667..000000000000
--- a/dev-python/pycparser/pycparser-2.14-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_compile() {
- distutils-r1_python_compile
- pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- nosetests || die
-}
diff --git a/dev-python/pycparser/pycparser-2.14.ebuild b/dev-python/pycparser/pycparser-2.14.ebuild
index 0b29b2dad409..c7fc55640f53 100644
--- a/dev-python/pycparser/pycparser-2.14.ebuild
+++ b/dev-python/pycparser/pycparser-2.14.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1 vcs-snapshot