summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-27 19:59:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-27 20:07:49 +0200
commitd2a9def05500f4e6f403ff56ad9cc54aede11ee7 (patch)
tree26cc3740e2d737fb5be38b0e554634b66393eb0d /dev-python/pycparser
parentnet-libs/uhttpmock: version bump 0.5.0 → 0.5.1 (diff)
downloadgentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.tar.gz
gentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.tar.bz2
gentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.zip
dev-python/pycparser: Enforce regenerating tables
Remove the pregenerated tables provided in the distfile to force regenerating them. Generate the tables for every Python implementation separately to avoid incompatibility/underoptimization problems (tables built by Python 3.5+ are incompatible with older Python versions that have 100 group-in-regex limit).
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/pycparser-2.18-r1.ebuild (renamed from dev-python/pycparser/pycparser-2.18.ebuild)19
1 files changed, 17 insertions, 2 deletions
diff --git a/dev-python/pycparser/pycparser-2.18.ebuild b/dev-python/pycparser/pycparser-2.18-r1.ebuild
index 292106b4124e..3fb094f6ff3f 100644
--- a/dev-python/pycparser/pycparser-2.18.ebuild
+++ b/dev-python/pycparser/pycparser-2.18-r1.ebuild
@@ -21,13 +21,28 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_compile() {
distutils-r1_python_compile
- pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
+
+ # note: tables built by py3.5+ are incompatible with older versions
+ # because of 100 group limit of 're' module -- just generate them
+ # separately optimized for each target instead
+ pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
"${PYTHON}" _build_tables.py || die
popd > /dev/null || die
}
python_test() {
- nosetests || die
+ # change workdir to avoid '.' import
+ nosetests -v -w tests || die
}