summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-05 09:31:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-05 09:53:24 +0100
commit628548932b44eb36b1994712b81372eb04e4a88b (patch)
treecf088161e06ddda0b0741ade19e9a281de426eae /dev-python/pycryptodome
parentdev-python/Faker: Bump to 12.1.0 (diff)
downloadgentoo-628548932b44eb36b1994712b81372eb04e4a88b.tar.gz
gentoo-628548932b44eb36b1994712b81372eb04e4a88b.tar.bz2
gentoo-628548932b44eb36b1994712b81372eb04e4a88b.zip
dev-python/pycryptodome: Bump to 3.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycryptodome')
-rw-r--r--dev-python/pycryptodome/Manifest1
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.14.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index 3c9af95faa47..f934f5c2f151 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1,3 +1,4 @@
DIST pycryptodome-3.12.0.tar.gz 15130980 BLAKE2B 5eb34a03523652d990ddfdd1eebcbbacea30bffbe4838289c195b07658a98814ebec322aaffbed7b3fa564bc005d52ea1e483dedcb9f40b65d00e50c28d78582 SHA512 67f2a814d74305614fdf9dfb633c4fd9d80d2064119d0ecab24ae52fd8ce4b6de1a1e82c6ba7bcf22fb7db1a5a850adf078e22317b4c07229cd7cb8cb7f1ffd4
DIST pycryptodome-3.13.0.tar.gz 15306369 BLAKE2B 97ef26868fb2be2f3240960d8debd897cb82c4a6f1ea1c179fc790693eb2e37de14cbf16bd7deafe0ca1d28983e9bee8583cbe8adde2fa50533cf2bd1274108c SHA512 daafdc80ae8df7f5f282adbdd3fbd9f848b03a3de0c21739b3bb973368daf721c9cd306e56c16baceeda4a0ebc3470abbc0cddc4e8409b5e4fe4255f3d62ec2e
DIST pycryptodome-3.14.0.tar.gz 15339838 BLAKE2B 804ceabfb5e29775df279a00eaadced776a10301e9bd254471b234f10c65fcfce507c8e51eb5dc5387eb81f856ccfe46ff035ca96a8acebf8b4f59c960fd35a4 SHA512 2f20a3a2bfef14a0f4c05587d64da3a4be7303ae37aaee02e49a3c7ef69009fa958e4b7151c1441f2cc63833cc29642d6d13c1006fb0f215743178d36c9de802
+DIST pycryptodome-3.14.1.tar.gz 15339859 BLAKE2B 72748a4eaf9f34be1ac3200a0ed0285a96111f52077b6d7cc5b4fa26599b6b8c6c17d79cdce4cabd7257cef840daf71440a78d00ded65deb52fa13e6b1b1efe6 SHA512 08e904aa2f3df19fcc75a8283fc867349617afe3919532912801d8abc9610f1cb64b878b56202cbdf0759cf5506ec5f793123093e21f18ba99acbf42fa4d9cf1
diff --git a/dev-python/pycryptodome/pycryptodome-3.14.1.ebuild b/dev-python/pycryptodome/pycryptodome-3.14.1.ebuild
new file mode 100644
index 000000000000..695065661243
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.14.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org/
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodome/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0=
+ >=dev-libs/libtomcrypt-1.18.2-r1:="
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+ !dev-python/pycrypto"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # make sure we're unbundling it correctly
+ rm -r src/libtom || die
+
+ distutils-r1_python_prepare_all
+}